/ Setembro 11, 2018/ Excel

A nova função SES (IFS), no Excel 2016 é uma alternativa a usar para uma série encadeada de funções SE, e quando há mais de uma condição a ser testada para encontrar o resultado correspondente.
Sabe que a função SE é uma das mais utilizadas no Excel e usar SE dentro de SE (funções SE encadeadas) tem sido uma prática comum, mas desafiadora ou confusa algumas vezes.
Já usa o “Se encadeado”?
Como deve ter constatado, a fórmula é uma das mais complexas do Excel e qualquer utilizador tem receio de aplicar.
Para quem não sabe, a fórmula =Se é usada para fazer uma verificação de alguma informação que passou ao Excel e este irá tomar um caminho caso a verificação seja verdadeira, ou outro caminho, caso a verificação seja falsa.
Suponhamos que temos uma coluna com as condições de nosso teste. Nós queremos inserir três condições na função SE.
• Se a condição for igual a 1 então queremos que a função retorne “um”;
• Se a condição for igual a 2, então queremos que a função retorne “dois”;
• Se a condição for igual a 3, então queremos que a função retorne “três”, caso contrário retorne “outro”.

Portanto, caso não possua o Microsoft Office recente, continue com o método antigo.
Já o =Se encadeado era utilizado para fazer algum cálculo onde quiséssemos considerar 3, 4 ou dezenas de condições. O problema é que para fazer um =Se encadeado é bastante complicado: porque tem que agregar a mesma com a fórmula =E ou então com a fórmula =Ou e então temos um risco enorme de erro e confusão.
Repare no exemplo que é apresentado:

=SE(E(C6>=5;C6<=10);”2%”;SE(E(C6>=11;C6<=15);”5%”;SE(E(C6>=16;C6<=29);”10%”;SE(C6>=30;”15%”))))

Veja quantos =Se e quantos =E em conjunto foram utilizados
Assim, com o último Office, a versão 2016, a Microsoft introduziu algumas novas fórmulas e entre elas, a =Ses que vai fazer o se encadeado de uma maneira muito mais fácil e simplificada.

SINTAXE DA FUNÇÃO SES
A sintaxe da função SES é:

=SES(condição1; o que faz se a 1 for verdade; condição2;o que faz se a 2 for verdade;condição n;o que faz se n for verdadeiro…)

Para ficar mais fácil, veja num exemplo prático. Será uma Lista de produtos, onde ao selecionar um produto, o Excel deverá retornar o preço do mesmo automaticamente, para isso utilizamos a função SE com várias condições, pois tínhamos vários produtos e cada um com seu preço. Bom, a fórmula que antes era:

=SE(A2=”Iphone 5S”;2600;SE(A2=”Iphone 6S”;3000;SE(A2=”Iphone 7S”;4000;2800)))

E, agora vai ser:

=SES(A2=”Iphone 5S”;2600;A2=”Iphone 6S”;3000;A2=”Iphone 7S”;4000;A2=”Nokia”;2800)

Assim, a Função SES dá um enorme jeito de fazer um Se encadeado, permitindo com facilidade executar e conseguir um resultado lógico, com diversas opções como conseguiram constatar a diferença.
A metade do tamanho e com risco quase 0 de se perder entre os argumentos.
Em breve, terei aqui exemplos práticos de como usar esta Função no Excel 2016.